ASP.Net Erros indesejáveis


Olá pessoal.

Para quem está acostumado a programar em php, python e utilizar Apache ou Nginx sabe que quando o seu servidor(Linux) sofre um pique de energia ou um desligamento inesperado, basta ligá-lo novamente e deixar que o próprio sistema operacional faça sua checagem de sistema de arquivos na sua inicialização. Então, depois de iniciar novamente, você percebe que seu Apache, Cherokee, Gunicorn ou Nginx continuam funcionando normalmente. Até o mais cabuloso pau no sistema de arquivos, a ponto de você ter de restaurá-lo, não irá danificar seus programas e você que programa na plataforma LInux, sabe disso, a não ser, claro, que seu HD tenha ido para o saco. MAS, isto não acontece sempre com o nosso amiguinho (Ru)Windows. Com certeza. O que você ganha em produtividade utilizando o Visual Studio programando em C#, você perde ficando refém deste sistema operacional. Então, para tentar me lembrar do que tenho que fazer quando ocorre um probleminha deste tipo(alguém tropeçou no fio e meu pc desligou, e depois que liguei novamente, corrompeu tudo), vou tentar fazer um tópico permanente dos erros que eu for encontrando e vou colocando aqui, para eu poder me lembrar de como proceder e para ajudar outros desesperados.

Então, vamos lá.

fonte: https://mastigado.wordpress.com

Erro 1:

antlr3.runtime’ could not be loaded ou Rastreamento do Carregamento de Assembly: As informações a seguir podem ser úteis para determinar por que o assembly ‘Antlr3.Runtime’ não pôde ser carregado.

Quando e como ocorreu:

Estava programando no Visual Studio e meu estabilizador desligou, então liguei o pc novamente e continuei a programar. Em seguida, ele desligou novamente, daí quando religuei o pc e voltei a programar, quando fui testar meu programa em ASP.Net dentro do Visual Studio, ao abrir o browser dei de cara com a tela abaixo.

Erro antlr3

antlr3.runtime’ could not be loaded

Como foi resolvido:

Abri o console do Nuget(Package Manage Console) no Visual Studio e digitei install-package antlr. Pronto, resolveu.

Erro 2:

Tentei fazer login em um sistema que já estava hospedado, mas que eu tinha acabado de refazer o seu banco de produção.

Quando e como ocorreu:

Após ter refeito o banco de dados que o meu sistema hospedado tentou acessar.

nao_e_possivel_autenticar

Não é possível autenticar no sistema

Como foi resolvido:

Fui em tabela por tabela do banco e refiz as suas permissões originais.

Erro 3:

Havia publicado uma aplicação Asp.Net MVC 4 sem alterar nenhuma linha do código gerado automaticamente pelo Visual Studio e após esta publicação no IIS de outra máquina, a app funcionava perfeitamente, até fazer uma alteração no código.

Quando e como ocorreu:

Depois de colocar um fragmento de código em um dos controllers do Asp.Net MVC que fazia alguma chamada implícita para o banco de dados, dei de cara com o erro abaixo.

Erro 3 Asp.Net MVCComo foi resolvido:

Adicionei em References do meu projeto C#, a minha camada de projeto que trabalhava com a conexão de banco de dados.

Abri o arquivo app.config desta minha camada que trabalhava com o banco e copiei a string de conexão com o banco que estava contida dentro da tag connectionStrings e colei dentro da tag connectionString contida dentro do arquivo Web.config do meu projeto Asp.Net MVC, deste jeito abaixo.

<connectionStrings>
     <add name="DefaultConnection" connectionString="Data Source=.\SQLEXPRESS;Initial Catalog=aspnet-MeuProjeto.Apresentacao-20150610155105;Integrated Security=SSPI" providerName="System.Data.SqlClient" />
</connectionStrings>

E como eu já utilizo o Entity Framework em meus projetos, fui até o menu View > Other Windows > Package Manager Console e após abrir o terminal, instalei o Entity Framework no meu projeto Asp.Net MVC 4. Utilizei o comando abaixo para instalá-lo.

Install-Package EntityFramework

Erro 4:

Como e quando ocorreu:

Hospedei uma aplicação Asp.Net MVC no servidor de produção e eis que o erro abaixo, surge.

 Error. An error occurred while processing your request.

Eu já havia tentado colocar meu arquivo Web.config igual a de outras apps que já havia feito, mas eu esqueci de um detalhe que vi num post do Stackoverflow.

Como foi resolvido:

<configuration>
   ...
   <system.web>
   ...
   <customErrors mode="Off" />
   ...
   </system.web>
   ...
</configuration>

Coloquei o parâmetro CustomErros mode com o valor Off e consegui ver o erro real.
fonte: https://mastigado.wordpress.com

Sobre Mastigado
Sou um daqueles que precisa mudar o mundo.

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

%d blogueiros gostam disto: